summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-25 02:12:58 +0100
committerPaul Spooren <mail@aparcar.org>2022-01-17 09:14:26 +0100
commit88204bfa82f982a986d2aa3e166a4c5946040308 (patch)
tree7d10a3c76c12f1cdf00ec192cb40efe823a4f0d2 /Makefile
parent87d489f67a35968242cd4f192dc363dc87056844 (diff)
downloadopenwrt-88204bfa82f982a986d2aa3e166a4c5946040308.tar.gz
openwrt-88204bfa82f982a986d2aa3e166a4c5946040308.tar.bz2
openwrt-88204bfa82f982a986d2aa3e166a4c5946040308.zip
treewide: drop use of which
Ubuntu started to flag which as deprecated and it seems which is not really standard and may vary across Distro. Drop the use of which and use the standard 'command -v' for this simple task. Which is still present in the prereq if some package/script still use which. A utility script called command_all.sh is implemented that will just mimic the output of which -a. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 39ab3ae4a5..d85df6c3cf 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' | head -n 1)
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)