summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-09-11 08:15:52 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-27 16:45:08 +0200
commita29d3bc48c40c6a2a93ae1806bea2ac26455cdbb (patch)
tree20c41b1a2a1ebd130584a9612f4f5b2b77367810 /Makefile
parentfcaea8b55135ef5db4d7c66230b8a5c4cb263991 (diff)
downloadopenwrt-a29d3bc48c40c6a2a93ae1806bea2ac26455cdbb.tar.gz
openwrt-a29d3bc48c40c6a2a93ae1806bea2ac26455cdbb.tar.bz2
openwrt-a29d3bc48c40c6a2a93ae1806bea2ac26455cdbb.zip
Makefile: fix stray \ warnings with grep-3.8
We simply grep for "/usr". So no need for "-E" or "\/". Furthermore, in the new grep versions this creates warnings. As written in the grep-3.8 announcement: Regular expressions with stray backslashes now cause warnings, as their unspecified behavior can lead to unexpected results. For example, '\a' and 'a' are not always equivalent <https://bugs.gnu.org/39678>. Fixes warnings in the form of: grep: warning: stray \ before / Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bfb52c5ddd..cbf9fa2cd1 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' -m 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)