diff options
author | Paul Spooren <mail@aparcar.org> | 2024-06-06 19:28:52 +0200 |
---|---|---|
committer | Christian Marangi <ansuelsmth@gmail.com> | 2024-06-17 17:51:31 +0200 |
commit | a8ff0c1b7e5aefb8bcd31e0eeb82d2c11399223f (patch) | |
tree | 40da490f401a43d7753fe1e1d52edc78ec6d66f7 /Makefile | |
parent | e3afc7047be26bb4fd461cc4f068f21cb9622ff0 (diff) | |
download | openwrt-a8ff0c1b7e5aefb8bcd31e0eeb82d2c11399223f.tar.gz openwrt-a8ff0c1b7e5aefb8bcd31e0eeb82d2c11399223f.tar.bz2 openwrt-a8ff0c1b7e5aefb8bcd31e0eeb82d2c11399223f.zip |
build: include tests/Makefile if available
Testing OpenWrt is important, and there is a test suite in the making.
For maximum convenience and minimal CI over-usage, make it simple to run
tests locally. The main Makefile now attempts to include
`tests/Makefile` and silently fails if it doesn't.
While the test suite[1] is still young, it provides good examples of how
to test things around OpenWrt: starting with shell scripts using
`bats`[2], followed by QEMU tests, and finally real device tests using
LabGrid[3]. This could lead to the creation of the best OpenWrt version
yet.
Please consult the `openwrt-tests.git` README.md for details on the
setup. Once installed you may run commands like the following:
* make tests/shell # run shell tests
* make tests/x86-64 # run and test x86/64 in QEMU
[1]: http://github.com/aparcar/openwrt-tests/
[2]: https://bats-core.readthedocs.io
[3]: https://labgrid.readthedocs.io
Signed-off-by: Paul Spooren <mail@aparcar.org>
Link: https://github.com/openwrt/openwrt/pull/15647
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -40,6 +40,9 @@ else include tools/Makefile include toolchain/Makefile +# Include the test suite Makefile if it exists +-include tests/Makefile + $(toolchain/stamp-compile): $(tools/stamp-compile) $(if $(CONFIG_BUILDBOT),toolchain_rebuild_check) $(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared $(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup) |