diff options
author | Petr Štetiar <ynezz@true.cz> | 2020-12-22 10:33:02 +0100 |
---|---|---|
committer | Petr Štetiar <ynezz@true.cz> | 2021-01-04 19:32:25 +0100 |
commit | c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb (patch) | |
tree | 5c7cce185683c1f467fb5de54b6acaee06d7f89b /Makefile | |
parent | 6773bee10753ae181257b544371101646822e80e (diff) | |
download | openwrt-c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb.tar.gz openwrt-c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb.tar.bz2 openwrt-c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb.zip |
build: replace which with Bash command built-in
`which` utility is not shipped by default for example on recent Arch
Linux and then any steps relying on its presence fails, like for example
following Python3 prereq build check:
$ python3 --version
Python 3.9.1
$ make
/bin/sh: line 1: which: command not found
/bin/sh: line 1: which: command not found
/bin/sh: line 1: which: command not found
...
Checking 'python3'... failed.
...
Fix this by switching to Bash builtin `command` which should provide
same functionality.
Fixes: FS#3525
Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -18,7 +18,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir world: -DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1) +DISTRO_PKG_CONFIG:=$(shell command -pv pkg-config | grep -E '\/usr' | head -n 1) export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH) ifneq ($(OPENWRT_BUILD),1) |