diff options
author | Michael Pratt <mcpratt@pm.me> | 2023-05-25 02:31:17 -0400 |
---|---|---|
committer | Petr Štetiar <ynezz@true.cz> | 2023-06-05 08:31:47 +0200 |
commit | d87a8aa148ddf93b199a759deb088fff73787025 (patch) | |
tree | 5f96d125bf2f59682c1fd6a8e96d48b80d1d3ead /Makefile | |
parent | 1bad93c42669061b0248ca5cff1d83e399a2ef1a (diff) | |
download | openwrt-d87a8aa148ddf93b199a759deb088fff73787025.tar.gz openwrt-d87a8aa148ddf93b199a759deb088fff73787025.tar.bz2 openwrt-d87a8aa148ddf93b199a759deb088fff73787025.zip |
treewide: add ORIG_PATH variable
Add a variable that stores the original value of $PATH
in the host system's shell, before Make alters it.
This can be useful for when it is necessary
to ignore symlinks and programs made by the build system.
Define this new variable before all instances of
'export PATH:=' or similar.
Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -15,6 +15,8 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir world: DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1) + +export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH)) export PATH:=$(if $(STAGING_DIR),$(abspath $(STAGING_DIR)/../host/bin),$(TOPDIR)/staging_dir/host/bin):$(PATH) ifneq ($(OPENWRT_BUILD),1) |