summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-17 02:51:10 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-02-23 21:10:56 +0100
commit90b1524f75023ad0f441e82773ca9e9b5d513e1a (patch)
tree5d528fc3c06c77a81e2f87e18367901e8fae1dea /include/autotools.mk
parent5e9b07ff365fc89e8eea271e63f202ff1afc33bd (diff)
downloadopenwrt-90b1524f75023ad0f441e82773ca9e9b5d513e1a.tar.gz
openwrt-90b1524f75023ad0f441e82773ca9e9b5d513e1a.tar.bz2
openwrt-90b1524f75023ad0f441e82773ca9e9b5d513e1a.zip
autotools.mk: fix gettext fixup
The update to gettext 0.21 broke packages that use autotools and gettext because the sed line was failing with the new version. Fix with a better sed expression. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 4b48b38992..eb52b55924 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -90,7 +90,7 @@ endef
define gettext_version_target
(cd $(PKG_BUILD_DIR) && \
- GETTEXT_VERSION=$(shell $(STAGING_DIR_HOSTPKG)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.*\([0-9]\.[0-9]\{2\}\.[0-9]\).*/\1/p' ) && \
+ GETTEXT_VERSION=$(shell $(STAGING_DIR_HOSTPKG)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -rne '1s/.*\b([0-9]\.[0-9]+(\.[0-9]+)?)\b.*/\1/p' ) && \
$(STAGING_DIR_HOST)/bin/sed \
-i $(PKG_BUILD_DIR)/configure.ac \
-e "s/AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \