summaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-10-19 18:16:25 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-20 16:13:56 +0200
commitd82c5884c6164856e830894d9bfacd218d430ba4 (patch)
tree23b5341e424db90eb00b66cd207190e89d18942a /include/cmake.mk
parent987458c2e1bb9afc3d635aca3c6e8942ed2e95f6 (diff)
downloadopenwrt-d82c5884c6164856e830894d9bfacd218d430ba4.tar.gz
openwrt-d82c5884c6164856e830894d9bfacd218d430ba4.tar.bz2
openwrt-d82c5884c6164856e830894d9bfacd218d430ba4.zip
treewide: make use of new toolchain define
Make use of new toolchain define. TOOLCHAIN_DIR should be used only for toolchain related packages and for everything else TOOLCHAIN_ROOT_DIR and other define should be used instead. Switch to new entry where possible. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 95870ffdb0..c82ba5f809 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -22,7 +22,7 @@ HOST_CMAKE_BINARY_DIR = $(HOST_BUILD_DIR)$(if $(CMAKE_BINARY_SUBDIR),/$(CMAKE_BI
MAKE_PATH = $(firstword $(CMAKE_BINARY_SUBDIR) .)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
- cmake_tool=$(TOOLCHAIN_DIR)/bin/$(1)
+ cmake_tool=$(firstword $(TOOLCHAIN_BIN_DIRS))/$(1)
else
cmake_tool=$(shell command -v $(1))
endif
@@ -49,7 +49,7 @@ CMAKE_AR:=$(call cmake_tool,$(TARGET_AR))
CMAKE_NM:=$(call cmake_tool,$(TARGET_NM))
CMAKE_RANLIB:=$(call cmake_tool,$(TARGET_RANLIB))
-CMAKE_FIND_ROOT_PATH:=$(STAGING_DIR)/usr;$(TOOLCHAIN_DIR)$(if $(CONFIG_EXTERNAL_TOOLCHAIN),;$(CONFIG_TOOLCHAIN_ROOT))
+CMAKE_FIND_ROOT_PATH:=$(STAGING_DIR)/usr;$(TOOLCHAIN_ROOT_DIR)
CMAKE_HOST_FIND_ROOT_PATH:=$(STAGING_DIR)/host;$(STAGING_DIR_HOSTPKG);$(STAGING_DIR_HOST)
CMAKE_SHARED_LDFLAGS:=-Wl,-Bsymbolic-functions
CMAKE_HOST_INSTALL_PREFIX = $(HOST_BUILD_PREFIX)