summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-25 16:40:05 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:12 +0100
commit84bd74057f0d2543ddbc7de2351b0a310df329c6 (patch)
tree7c7e358aedf5930eeba27392e3123702503556e5 /include/download.mk
parentdad48c6438f0a4c42ad34842a88e82280d971d90 (diff)
downloadopenwrt-84bd74057f0d2543ddbc7de2351b0a310df329c6.tar.gz
openwrt-84bd74057f0d2543ddbc7de2351b0a310df329c6.tar.bz2
openwrt-84bd74057f0d2543ddbc7de2351b0a310df329c6.zip
build: use mkhash to replace various quirky md5sum/openssl calls
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 09b929bd77..b87686dd07 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -61,7 +61,7 @@ else
check_warn = $(if $(filter-out undefined,$(origin F_$(1))),$(filter ,$(shell $(call F_$(1),$(2),$(3),$(4)) >&2)),$(check_warn_nofix))
endif
-gen_sha256sum = $(shell openssl dgst -sha256 $(DL_DIR)/$(1) | awk '{print $$2}')
+gen_sha256sum = $(shell mkhash sha256 $(DL_DIR)/$(1))
ifdef FIXUP
F_hash_deprecated = $(SCRIPT_DIR)/fixup-makefile.pl $(CURDIR)/Makefile fix-hash $(3) $(call gen_sha256sum,$(1)) $(2)