summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 00:13:33 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 00:19:18 +0200
commit4ada2fd2768cba671c3289ce9eb8f5c9c728da1f (patch)
tree162f10b2ccd542f3435335417a6ff5ae519e5312 /include/host-build.mk
parent7064a849ce3342428c8e120e225b6b45c58e95cd (diff)
downloadopenwrt-4ada2fd2768cba671c3289ce9eb8f5c9c728da1f.tar.gz
openwrt-4ada2fd2768cba671c3289ce9eb8f5c9c728da1f.tar.bz2
openwrt-4ada2fd2768cba671c3289ce9eb8f5c9c728da1f.zip
include/host-build.mk: fix ACLOCAL_INCLUDE
It seems the intention was to add both $(STAGING_DIR_HOST)/... and $(STAGING_DIR)/host/... instead of passing $(STAGING_DIR_HOST) twice. This makes the definition match HOST_CPPFLAGS and HOST_LDFLAGS. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 0b10c7cdf9..688f8d8442 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -133,7 +133,7 @@ define Download/default
endef
define Host/Exports/Default
- $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-* $(if $(IS_PACKAGE_BUILD),$$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*)),-I $$(p))
+ $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-* $(if $(IS_PACKAGE_BUILD),$$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*)),-I $$(p))
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig