summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-14 15:36:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:25 +0100
commit7a315b0b5d6aa91695853a8647383876e4b49a7a (patch)
treeca99d91b9ec9408e37d30f2983847fc5a500d4a7 /include/host-build.mk
parent720b99215da295a2e7b4acdef30b58bec6acedc2 (diff)
downloadopenwrt-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.gz
openwrt-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.bz2
openwrt-7a315b0b5d6aa91695853a8647383876e4b49a7a.zip
build: implement make check and make package/X/check
This is intended to be used for a wide array of package sanity checks. The first check that is implemented is for the hash of downloaded files. It checks: - Missing hash - Use of SHA256 instead of MD5 - dl/<file> hash not matching hash in makefile - deprecated MD5SUM variable The deprecated MD5SUM variable check is skipped for feeds/ until OpenWrt is updated as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 1ba849f88d..e11e3edd09 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -136,9 +136,8 @@ Host/Exports=$(Host/Exports/Default)
.NOTPARALLEL:
ifndef DUMP
- define HostBuild
+ define HostBuild/Core
$(if $(HOST_QUILT),$(Host/Quilt))
- $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
$(if $(DUMP),,$(call HostHost/Autoclean))
$(HOST_STAMP_PREPARED):
@@ -198,3 +197,8 @@ ifndef DUMP
clean:
endif
+
+define HostBuild
+ $(HostBuild/Core)
+ $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+endef