summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2017-10-03 12:46:09 +0200
committerMathias Kresin <dev@kresin.me>2017-10-06 08:28:41 +0200
commit254061ee97b9511f0d8981e3ea43406119e35ce4 (patch)
tree9b3755718b5269f2874362cde4ac0488f78e1e9b /include/image-commands.mk
parent90805b16b6d17dff861d456edf829858386ec559 (diff)
downloadopenwrt-254061ee97b9511f0d8981e3ea43406119e35ce4.tar.gz
openwrt-254061ee97b9511f0d8981e3ea43406119e35ce4.tar.bz2
openwrt-254061ee97b9511f0d8981e3ea43406119e35ce4.zip
build: add mktplinkfw2 hardcoded values to makefile
This patch adds all the board-specific values currently hardcoded in mktplinkfw2.c back to the respective device declarations in the makefiles. The rationale is to avoid modifying the source code every time a new board or board variant is added. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index acf25d64da..4fe8c0f456 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -249,14 +249,19 @@ endef
define Build/tplink-v2-header
$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
- -c -V "ver. 2.0" -B $(TPLINK_BOARD_ID) $(1) -k $@ -o $@.new
+ -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) \
+ -w $(TPLINK_HWREVADD) -F "$(TPLINK_FLASHLAYOUT)" \
+ -T $(TPLINK_HVERSION) -V "ver. 2.0" \
+ -k $@ -o $@.new $(1)
@mv $@.new $@
endef
define Build/tplink-v2-image
$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
- -a 0x4 -j -V "ver. 2.0" -B $(TPLINK_BOARD_ID) $(1) \
- -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) \
+ -w $(TPLINK_HWREVADD) -F "$(TPLINK_FLASHLAYOUT)" \
+ -T $(TPLINK_HVERSION) -V "ver. 2.0" -a 0x4 -j \
+ -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new $(1)
cat $@.new >> $@
rm -rf $@.new
endef