summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-12-14 11:39:17 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2022-12-18 13:18:09 +0100
commit47df168dd279d52127f6bbc623e79bdeeb6c8fd4 (patch)
treec7db5c515bb6ab27f8ef635896cd0d8450e554e4 /include/image-commands.mk
parent3f201d1f8ece4ed363428f353558d44f9dbe98a5 (diff)
downloadopenwrt-47df168dd279d52127f6bbc623e79bdeeb6c8fd4.tar.gz
openwrt-47df168dd279d52127f6bbc623e79bdeeb6c8fd4.tar.bz2
openwrt-47df168dd279d52127f6bbc623e79bdeeb6c8fd4.zip
image-commands.mk: Be consistent in command invocation
Most/all other tools use the staging dir prefix, gzip should as well. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Acked-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 41e1c96948..074e40e4e8 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -307,7 +307,7 @@ define Build/fit
endef
define Build/gzip
- gzip -f -9n -c $@ $(1) > $@.new
+ $(STAGING_DIR_HOST)/bin/gzip -f -9n -c $@ $(1) > $@.new
@mv $@.new $@
endef