summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2022-11-28 17:37:20 -0800
committerDaniel Golle <daniel@makrotopia.org>2023-01-17 00:16:35 +0000
commit4a444e576fd26764ed11aed8c3bdf2281bba3cc6 (patch)
tree9673e3d0664f65225f3b8feda8c005cbfe1ab63b /include/image-commands.mk
parent32e99ed06972e4295cec7ae57b2c55eb63566461 (diff)
downloadopenwrt-4a444e576fd26764ed11aed8c3bdf2281bba3cc6.tar.gz
openwrt-4a444e576fd26764ed11aed8c3bdf2281bba3cc6.tar.bz2
openwrt-4a444e576fd26764ed11aed8c3bdf2281bba3cc6.zip
build: fix incomplete initramfs compression options
Requires: tools/lz4, tools/lzop complete the wiring so that these options work: * `CONFIG_KERNEL_INITRAMFS_COMPRESSION_LZO` * `CONFIG_KERNEL_INITRAMFS_COMPRESSION_LZ4` Signed-off-by: Tony Butler <spudz76@gmail.com> [remove blocking dependencies for separate ramdisk, fix lzop options] Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index ff8acf96c4..70055cc576 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -277,7 +277,9 @@ endef
define Build/initrd_compression
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_BZIP2),.bzip2) \
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_GZIP),.gzip) \
+ $(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZ4),.lz4) \
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZMA),.lzma) \
+ $(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZO),.lzo) \
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_XZ),.xz) \
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_ZSTD),.zstd)
endef