summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2021-09-20 12:16:42 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-28 17:17:22 +0100
commit6db4a0372a726ebc1720adf308d698a5df9f1af1 (patch)
treefddd02784660f1f8e4c65c6d575f6b6fa2865909 /include/image-commands.mk
parent5a305e429facce7fae71f5589b4adbb55b918c9c (diff)
downloadopenwrt-6db4a0372a726ebc1720adf308d698a5df9f1af1.tar.gz
openwrt-6db4a0372a726ebc1720adf308d698a5df9f1af1.tar.bz2
openwrt-6db4a0372a726ebc1720adf308d698a5df9f1af1.zip
build: image: explicitly pass --rootfs to append-ubi
Rootfs is now optional in ubinize-image.sh and requires --rootfs flag instead of just passing the rootfs image as the argument before ubinize opts. So, simply add --rootfs flag before the $(IMAGE_ROOTFS). Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 23c7bd6133..4b5ff36ebe 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -112,7 +112,7 @@ define Build/append-ubi
$(if $(UBOOTENV_IN_UBI),--uboot-env) \
$(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
$(foreach part,$(UBINIZE_PARTS),--part $(part)) \
- $(IMAGE_ROOTFS) \
+ --rootfs $(IMAGE_ROOTFS) \
$@.tmp \
-p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
$(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \