summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-01-01 21:00:36 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-29 23:50:28 +0900
commit957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb (patch)
tree44238e23a15f6b0f89f303b1d7b00def6b8f5261 /include/image-commands.mk
parent0c568d044fac166e803ab6a9bcd2f18d31309f9f (diff)
downloadopenwrt-957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb.tar.gz
openwrt-957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb.tar.bz2
openwrt-957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb.zip
kirkwood: add support for ipTIME NAS1
ipTIME NAS1 is a 1-bay NAS, based on Marvell Kirkwood SoC. Specifications: * SoC: 88F6281 * RAM: 256 MiB * Flash: SPI NOR 16 MiB * SATA: 1x 3Gb/s * Ethernet: 1x 1GbE * USB: 1x 2.0 * Fan: 2 speed level * UART: JP1 (115200 8N1) * Pinout: [3V3] (TXD) (RXD) (GND) Notes: * There are several variants of the model name: "NAS-I", "NASI", "NAS1". Here "NAS1" is adopted for consistent naming scheme. * The reset button is also a USB copy button in stock FW, but in this patch the former is the only default behavior. Installation via web interface: 1. Flash sysupgrade image through the stock web interface. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 158af853a5..eda3fee94b 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -295,6 +295,11 @@ define Build/install-dtb
)
endef
+define Build/iptime-naspkg
+ $(STAGING_DIR_HOST)/bin/iptime-naspkg $(1) $@ $@.new
+ mv $@.new $@
+endef
+
define Build/jffs2
rm -rf $(KDIR_TMP)/$(DEVICE_NAME)/jffs2 && \
mkdir -p $(KDIR_TMP)/$(DEVICE_NAME)/jffs2/$$(dirname $(1)) && \