summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDavid Yang <mmyangfl@gmail.com>2023-02-08 09:59:27 +0800
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-20 21:29:25 +0200
commita8a2a95351d711133e220c5c618822d3b72358ac (patch)
treed4f46f91d072e21f0ce9b33e05b462fcf74e163c /include/image-commands.mk
parentaa28e91404ed7c4c3786a289fbf206c13adb9762 (diff)
downloadopenwrt-a8a2a95351d711133e220c5c618822d3b72358ac.tar.gz
openwrt-a8a2a95351d711133e220c5c618822d3b72358ac.tar.bz2
openwrt-a8a2a95351d711133e220c5c618822d3b72358ac.zip
build: Allow specifying uImage time
Some U-Boot checks for a specified uImage time and refuses to boot if mismatched. This patch fixes it by recognizing UIMAGE_TIME parameter. Signed-off-by: David Yang <mmyangfl@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 6c385b85e8..ea602662a5 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -581,6 +581,7 @@ define Build/tplink-v2-image
endef
define Build/uImage
+ $(if $(UIMAGE_TIME),SOURCE_DATE_EPOCH="$(UIMAGE_TIME)") \
mkimage \
-A $(LINUX_KARCH) \
-O linux \