summaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-01 16:47:34 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-30 19:44:41 +0100
commitac5671f46cb4a300e2a8ae00db70c248828367f5 (patch)
tree546f7d3f903edc844b2c11d534999ef2e18c1fcf /include/image.mk
parent278512665094888d3c007fdd74e090496d6c811d (diff)
downloadopenwrt-ac5671f46cb4a300e2a8ae00db70c248828367f5.tar.gz
openwrt-ac5671f46cb4a300e2a8ae00db70c248828367f5.tar.bz2
openwrt-ac5671f46cb4a300e2a8ae00db70c248828367f5.zip
kernel: remove obsolete kernel version switches for 4.19
This removes switches dependent on kernel version 4.19 as well as several packages/modules selected only for that version. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk18
1 files changed, 6 insertions, 12 deletions
diff --git a/include/image.mk b/include/image.mk
index eb047041fc..de08d04aa4 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -162,18 +162,12 @@ DTC_FLAGS += \
-Wno-unit_address_format \
-Wno-pci_bridge \
-Wno-pci_device_bus_num \
- -Wno-pci_device_reg
-ifeq ($(strip $(call kernel_patchver_ge,4.17.0)),1)
- DTC_FLAGS += \
- -Wno-avoid_unnecessary_addr_size \
- -Wno-alias_paths
-endif
-ifeq ($(strip $(call kernel_patchver_ge,4.18.0)),1)
- DTC_FLAGS += \
- -Wno-graph_child_address \
- -Wno-graph_port \
- -Wno-unique_unit_address
-endif
+ -Wno-pci_device_reg \
+ -Wno-avoid_unnecessary_addr_size \
+ -Wno-alias_paths \
+ -Wno-graph_child_address \
+ -Wno-graph_port \
+ -Wno-unique_unit_address
define Image/pad-to
dd if=$(1) of=$(1).new bs=$(2) conv=sync