summaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2024-07-03 03:15:46 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2024-07-03 13:10:08 +0200
commita1440747f2edb507c819f63f93228cd16c1cdcb5 (patch)
tree0f9cf4a17a65853ff5136a6baf033d36300f6208 /include/kernel-build.mk
parentd55083fbcaea9cdd2ebc10a2d38989ad485a5357 (diff)
downloadopenwrt-a1440747f2edb507c819f63f93228cd16c1cdcb5.tar.gz
openwrt-a1440747f2edb507c819f63f93228cd16c1cdcb5.tar.bz2
openwrt-a1440747f2edb507c819f63f93228cd16c1cdcb5.zip
build: fix missing SOURCE_VERSION variable
The recipe Download/git-kernel uses DownloadMethod/git which now requires a definition of SOURCE_VERSION instead of VERSION due to Validate/git being used to check for the variables. Rename the variable as intended to match with the others that were renamed in the referenced commit. This fixes the following Makefile parse error when downloading a specific kernel repository version when configured with the CONFIG_KERNEL_GIT_CLONE_URI option: Makefile:19: *** Download/git-kernel is missing the SOURCE_VERSION field.. Stop. Fixes: 9fc79e2e2 ("download: don't overwrite VERSION variable") Signed-off-by: Michael Pratt <mcpratt@pm.me> Link: https://github.com/openwrt/openwrt/pull/15858 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index c42dae0049..48e00fa4c6 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -51,7 +51,7 @@ endif
define Download/git-kernel
URL:=$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI))
PROTO:=git
- VERSION:=$(CONFIG_KERNEL_GIT_REF)
+ SOURCE_VERSION:=$(CONFIG_KERNEL_GIT_REF)
FILE:=$(LINUX_SOURCE)
SUBDIR:=linux-$(LINUX_VERSION)
OPTS:=$(KERNEL_GIT_OPTS)