summaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-09-24 19:57:26 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-09-24 23:52:14 +0200
commit1ce2691bf3dacca41559a20e7f1a55587469dfae (patch)
tree2675e48905b479e277ea8a0be99e58c97c08b632 /include/kernel-defaults.mk
parentb02b95d1b0816274e5cf221071e0f52482c7537a (diff)
downloadopenwrt-1ce2691bf3dacca41559a20e7f1a55587469dfae.tar.gz
openwrt-1ce2691bf3dacca41559a20e7f1a55587469dfae.tar.bz2
openwrt-1ce2691bf3dacca41559a20e7f1a55587469dfae.zip
uml: headers are not exportable
When building UML this showed up as of late (2022-09-01): | Makefile:1335: *** Headers not exportable for UML. Stop. This message popped up because of an upstream patch that fixed this error not showing up sooner. For more information see: <https://lore.kernel.org/lkml/20220901011252.550830-1-masahiroy@kernel.org/T/> Now, I don't think we can just skip the kernel headers. Some userspace applications are going to need these. So, The next best alternative I can think of, is to go with the headers by the host arch the UML is compiled for. (Technically, ARCH= should be safe for all other targets as well... But let's not poke a hornet's nest) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 2e21392016..dcba319a0f 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -117,7 +117,7 @@ define Kernel/Configure/Default
cp $(LINUX_DIR)/.config.set $(LINUX_DIR)/.config; \
cp $(LINUX_DIR)/.config.set $(LINUX_DIR)/.config.prev; \
}
- $(_SINGLE) [ -d $(LINUX_DIR)/user_headers ] || $(KERNEL_MAKE) INSTALL_HDR_PATH=$(LINUX_DIR)/user_headers headers_install
+ $(_SINGLE) [ -d $(LINUX_DIR)/user_headers ] || $(KERNEL_MAKE) $(if $(findstring uml,$(BOARD)),ARCH=$(ARCH)) INSTALL_HDR_PATH=$(LINUX_DIR)/user_headers headers_install
grep '=[ym]' $(LINUX_DIR)/.config.set | LC_ALL=C sort | $(MKHASH) md5 > $(LINUX_DIR)/.vermagic
endef