summaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorLeonardo Mörlein <me@irrelefant.net>2021-05-09 22:28:15 +0200
committerPetr Štetiar <ynezz@true.cz>2021-05-13 15:13:15 +0200
commitb993b68b6ca8444b5227a0c18df4600b37ac565c (patch)
treea55300e2e43a57fa46a534d1135eee006a4b6d71 /include/kernel-defaults.mk
parentce8af0ace04bb43e8156940c771b4058fa83d27a (diff)
downloadopenwrt-b993b68b6ca8444b5227a0c18df4600b37ac565c.tar.gz
openwrt-b993b68b6ca8444b5227a0c18df4600b37ac565c.tar.bz2
openwrt-b993b68b6ca8444b5227a0c18df4600b37ac565c.zip
build: introduce $(MKHASH)
Before this commit, it was assumed that mkhash is in the PATH. While this was fine for the normal build workflow, this led to some issues if make TOPDIR="$(pwd)" -C "$pkgdir" compile was called manually. In most of the cases, I just saw warnings like this: make: Entering directory '/home/.../package/gluon-status-page' bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found [...] While these were only warnings and the package still compiled sucessfully, I also observed that some package even fail to build because of this. After applying this commit, the variable $(MKHASH) is introduced. This variable points to $(STAGING_DIR_HOST)/bin/mkhash, which is always the correct path. Signed-off-by: Leonardo Mörlein <me@irrelefant.net>
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 4b0b136a03..82bc32256d 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -116,7 +116,7 @@ define Kernel/Configure/Default
cp $(LINUX_DIR)/.config.set $(LINUX_DIR)/.config.prev; \
}
$(_SINGLE) [ -d $(LINUX_DIR)/user_headers ] || $(KERNEL_MAKE) INSTALL_HDR_PATH=$(LINUX_DIR)/user_headers headers_install
- grep '=[ym]' $(LINUX_DIR)/.config.set | LC_ALL=C sort | mkhash md5 > $(LINUX_DIR)/.vermagic
+ grep '=[ym]' $(LINUX_DIR)/.config.set | LC_ALL=C sort | $(MKHASH) md5 > $(LINUX_DIR)/.vermagic
endef
define Kernel/Configure/Initramfs
@@ -186,5 +186,3 @@ define Kernel/Clean/Default
rm -f $(LINUX_KERNEL)
$(_SINGLE)$(MAKE) -C $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION) clean
endef
-
-