summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-12-17 13:07:19 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2018-12-18 20:04:17 +0000
commiteda3094eb974cc0540562ae710ea543e037632ba (patch)
treef9ac55c4589640182634d76f941b649e7d07b563 /include/kernel.mk
parent583af20b8b377dbc709f3a30d3d844106186a3d7 (diff)
downloadopenwrt-eda3094eb974cc0540562ae710ea543e037632ba.tar.gz
openwrt-eda3094eb974cc0540562ae710ea543e037632ba.tar.bz2
openwrt-eda3094eb974cc0540562ae710ea543e037632ba.zip
build: fix build dependency of kmod .ipk with version filtered files
We need to use resolved file list as prerequisites for repacking kmod .ipk files. Note that currently version_filter uses a Makefile macro KERNEL_PATCHVER that should be available at ipk building time. Reported-by: Rafał Miłecki <zajec5@gmail.com> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 38613756c7..19ecf4fa9a 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -259,7 +259,7 @@ $(call KernelPackage/$(1)/config)
endif
$$(eval $$(call BuildPackage,kmod-$(1)))
- $$(IPKG_kmod-$(1)): $$(wildcard $$(FILES))
+ $$(IPKG_kmod-$(1)): $$(wildcard $$(call version_filter,$$(FILES)))
endef