summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2020-01-17 18:47:33 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-01-26 19:20:08 +0100
commiteec50c73c4c9cca89a4bca13a40517b262192fea (patch)
treea41c18cd8c5ea041084938f70c13601270d15c9c /include/kernel.mk
parenta461f984c450a49bce1cac191620a8ee2a3329c0 (diff)
downloadopenwrt-eec50c73c4c9cca89a4bca13a40517b262192fea.tar.gz
openwrt-eec50c73c4c9cca89a4bca13a40517b262192fea.tar.bz2
openwrt-eec50c73c4c9cca89a4bca13a40517b262192fea.zip
build: Add KBUILD_HOSTLDLIBS
In Linux kernel commit 8377bd2b9ee1 ("kbuild: Rename HOST_LOADLIBES to KBUILD_HOSTLDLIBS") HOST_LOADLIBES was renamed to KBUILD_HOSTLDLIBS. This patch adapts the OpenWrt kernel build to this new variable. Without this change the kernel host tools would not link against the libraries found in the staging directory. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 439e910ebf..02d0949a72 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -114,6 +114,7 @@ KERNEL_MAKE_FLAGS = \
KBUILD_BUILD_TIMESTAMP="$(KBUILD_BUILD_TIMESTAMP)" \
KBUILD_BUILD_VERSION="0" \
HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib" \
+ KBUILD_HOSTLDLIBS="-L$(STAGING_DIR_HOST)/lib" \
CONFIG_SHELL="$(BASH)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
$(if $(PKG_BUILD_ID),LDFLAGS_MODULE=--build-id=0x$(PKG_BUILD_ID)) \