summaryrefslogtreecommitdiffstats
path: root/include/meson.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-11-22 00:51:08 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-12-05 18:49:14 +0100
commit75093d1b1de7af82acd3b8bcc61f308c37493400 (patch)
tree2d34b0f608a409ebc32e1c9ccdacc17610fac3ba /include/meson.mk
parent362695acdfa78ad6206ac385962ded589dad5b7c (diff)
downloadopenwrt-75093d1b1de7af82acd3b8bcc61f308c37493400.tar.gz
openwrt-75093d1b1de7af82acd3b8bcc61f308c37493400.tar.bz2
openwrt-75093d1b1de7af82acd3b8bcc61f308c37493400.zip
tools/meson: update to 0.60.1
change meson binary to use py extension. Fixes issue with meson's symbolextractor using the host python instead of the system one. We intentionally use a .py extension here so that meson launches additional python scripts with the same build host python interpreter as itself is running under (and not the host package one once it becomes available) Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/meson.mk')
-rw-r--r--include/meson.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/meson.mk b/include/meson.mk
index ae17e18d2d..e101de4d89 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -56,7 +56,7 @@ MESON_CPU:="$(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))"
endif
define Meson
- $(2) $(STAGING_DIR_HOST)/bin/$(PYTHON) $(STAGING_DIR_HOST)/bin/meson $(1)
+ $(2) $(STAGING_DIR_HOST)/bin/$(PYTHON) $(STAGING_DIR_HOST)/bin/meson.py $(1)
endef
define Meson/CreateNativeFile