summaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-03-17 18:43:10 +0100
committerPaul Spooren <mail@aparcar.org>2024-03-22 22:14:22 +0100
commite8725a932e16eaf6ec51add8c084d959cbe32ff2 (patch)
tree1e6e0a3731bf9c4860b6d13fa08bea226f999a6f /include/package-defaults.mk
parent36acf88fe0d974a7de5c3be5d3303048c54ce6fb (diff)
downloadopenwrt-e8725a932e16eaf6ec51add8c084d959cbe32ff2.tar.gz
openwrt-e8725a932e16eaf6ec51add8c084d959cbe32ff2.tar.bz2
openwrt-e8725a932e16eaf6ec51add8c084d959cbe32ff2.zip
treewide: use APK compatible version schema
Different from OPKG, APK uses a deterministic version schema which chips the version into chunks and compares them individually. This enforces a certain schema which was previously entirely flexible. - Releases are added at the very and end prefixed with an `r` like `1.2.3-r3`. - Hashes are prefixed with a `~` like `1.2.3~abc123`. - Dates become semantic versions, like `2024.04.01` - Extra tags are possible like `_git`, `_alpha` and more. For full details see the APK test list: https://gitlab.alpinelinux.org/alpine/apk-tools/-/blob/master/test/version.data Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 392aad0d5d..37de9f0ccb 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -23,7 +23,7 @@ define Package/Default
SOURCE:=$(patsubst $(TOPDIR)/%,%,$(patsubst $(TOPDIR)/package/%,feeds/base/%,$(CURDIR)))
ifneq ($(PKG_VERSION),)
ifneq ($(PKG_RELEASE),)
- VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+ VERSION:=$(PKG_VERSION)-r$(PKG_RELEASE)
else
VERSION:=$(PKG_VERSION)
endif