summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-24 12:48:27 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 12:51:39 +0100
commit790bce92adce6fc52a5fe68ac05b1018e171af28 (patch)
tree7cc39997cdd35d532b8feb21a2ad590d06a31e09 /include/package-ipkg.mk
parent0e70f69a35fd79be781c859c12487b626e243e96 (diff)
downloadopenwrt-790bce92adce6fc52a5fe68ac05b1018e171af28.tar.gz
openwrt-790bce92adce6fc52a5fe68ac05b1018e171af28.tar.bz2
openwrt-790bce92adce6fc52a5fe68ac05b1018e171af28.zip
build: formatting fixes for per-provide ABI_VERSION suffixes
- Filter out potential duplicates with the package name (e.g. when renaming libfoo1 w/ ABI_VERSION:=1 to libfoo) - Use the GetABISuffix macro to properly separate the suffix with a dash in case the basename ends with a number Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 1cb4da8e30..9ca4879bfa 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -162,7 +162,7 @@ Package: $(1)$$(ABIV_$(1))
Version: $(VERSION)
$$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
)$$(call addfield,Conflicts,$$(call mergelist,$(CONFLICTS))
-)$$(call addfield,Provides,$$(call mergelist,$(PROVIDES)$$(if $$(ABIV_$(1)), $(1) $(foreach provide,$(PROVIDES),$(provide)$$(ABIV_$(1)))))
+)$$(call addfield,Provides,$$(call mergelist,$$(filter-out $(1)$$(ABIV_$(1)),$(PROVIDES)$$(if $$(ABIV_$(1)), $(1) $(foreach provide,$(PROVIDES),$(provide)$$(call GetABISuffix,$(provide))))))
)$$(call addfield,Alternatives,$$(call mergelist,$(ALTERNATIVES))
)$$(call addfield,Source,$(SOURCE)
)$$(call addfield,SourceName,$(1)