summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2020-06-12 21:43:46 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-11 15:19:53 +0200
commit2ca084ccaae619ac8031e902c66817d021ac6fd5 (patch)
tree821349dcff0400e92ff84659554bc66f4197c481 /include/package.mk
parent23de93a5216bf1c24c4e4c71f6cad4455c3cfa2c (diff)
downloadopenwrt-2ca084ccaae619ac8031e902c66817d021ac6fd5.tar.gz
openwrt-2ca084ccaae619ac8031e902c66817d021ac6fd5.tar.bz2
openwrt-2ca084ccaae619ac8031e902c66817d021ac6fd5.zip
build: improve ccache support
Set CCACHE_DIR to $(TOPDIR)/.ccache and CCACHE_BASEDIR to $(TOPDIR). This allows to do clean and dirclean. Cache hit rate for test build after dirclean is ~65%. If CCACHE is enabled stats are printed out at the end of building process. CCACHE_DIR config variable allows to override default, which could be useful when sharing cache with many builds. cacheclean make target allows to clean the cache. Changes from v1: - remove ccache directory using CCACHE_DIR variable - remove ccache leftovers from sdk and toolchain make files - introduce CONFIG_CCACHE_DIR variable - introduce cacheclean make target Signed-off-by: Roman Yeryomin <roman@advem.lv>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 0575692742..a93d6b78f3 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -173,7 +173,9 @@ define Build/Exports/Default
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
$(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
$(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache)
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_BASEDIR:=$(TOPDIR))
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache))
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion)
endef
Build/Exports=$(Build/Exports/Default)