summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-22 20:16:15 +0100
committerFelix Fietkau <nbd@nbd.name>2017-03-22 20:17:20 +0100
commit89118da865a34ed9537a088196d81ca9e37cb983 (patch)
treeb5f87a8aa9dfe3eb20e128cfa796c5a492bed703 /include/package.mk
parentc5e245a475b4b4c5602eae0e8f320e2b410f81ed (diff)
downloadopenwrt-89118da865a34ed9537a088196d81ca9e37cb983.tar.gz
openwrt-89118da865a34ed9537a088196d81ca9e37cb983.tar.bz2
openwrt-89118da865a34ed9537a088196d81ca9e37cb983.zip
build: fix STAMP_PREPARED with quilt
quilt.mk needs to be included first, to ensure that STAMP_PREPARED does not include the hash if quilt is used. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index ff580f5e7c..c5c335a198 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -39,6 +39,7 @@ include $(INCLUDE_DIR)/hardening.mk
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
+include $(INCLUDE_DIR)/quilt.mk
find_library_dependencies = $(wildcard $(patsubst %,$(STAGING_DIR)/pkginfo/%.version, \
$(filter-out $(BUILD_PACKAGES),$(foreach dep, \
@@ -88,7 +89,6 @@ endif
PKG_INSTALL_STAMP:=$(PKG_INFO_DIR)/$(PKG_DIR_NAME).$(if $(BUILD_VARIANT),$(BUILD_VARIANT),default).install
-include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/package-defaults.mk
include $(INCLUDE_DIR)/package-dumpinfo.mk
include $(INCLUDE_DIR)/package-ipkg.mk