summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-07-24 15:23:05 +0200
committerJo-Philipp Wich <jo@mein.io>2018-07-24 15:23:05 +0200
commit991c7a4f69976f72bcee3f76d6917b224da45ea1 (patch)
tree0c35c843944cf999d3b0adf30a32b4bc4b95bd2f /include/package.mk
parenta6f4c7bce8c62d2dded5c8c12f7f118e2a6c9ee5 (diff)
downloadopenwrt-991c7a4f69976f72bcee3f76d6917b224da45ea1.tar.gz
openwrt-991c7a4f69976f72bcee3f76d6917b224da45ea1.tar.bz2
openwrt-991c7a4f69976f72bcee3f76d6917b224da45ea1.zip
build: do not override CCACHE_DIR when ccache is disabled
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 2473eecb92..a03db11119 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -144,7 +144,7 @@ define Build/Exports/Default
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
$(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
$(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
- $(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache)
endef
Build/Exports=$(Build/Exports/Default)