summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2023-11-13 23:32:12 +0100
committerPaul Spooren <mail@aparcar.org>2023-11-13 23:33:40 +0100
commit09b7e1955c92e0b05197174b7bd4aef2c4073a35 (patch)
tree4e1fb4501fbb22d512404e24f7f3af92d44b2fe1 /include/prereq-build.mk
parent3f5e0fb66f45a0509698d17c406623b9c0ef0fad (diff)
downloadopenwrt-09b7e1955c92e0b05197174b7bd4aef2c4073a35.tar.gz
openwrt-09b7e1955c92e0b05197174b7bd4aef2c4073a35.tar.bz2
openwrt-09b7e1955c92e0b05197174b7bd4aef2c4073a35.zip
Revert "prereq-build: add Python 3.12 support"
This reverts commit 7ceb76ca3a37ba6b722df39ba0838909fa7cf7b4. Python 3.12 removes the distutils package and is therefore not compatible. We have to check downstream what relies on distutils before adding actual support for Python 3.12. Sorry for the noise. With this in-place, the macOS CI job fails and turns things red, revert for now. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 2378f5ad90..49340ce3e4 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -182,7 +182,6 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
- python3.12 -V 2>&1 | grep 'Python 3', \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
@@ -191,7 +190,6 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
- python3.12 -V 2>&1 | grep 'Python 3', \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \