summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2020-12-04 19:16:26 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2020-12-07 18:23:13 +0200
commit0ba83a757728185eabd965e07331508923cca825 (patch)
tree91c89a5ebde7da21918334c4019de080c07d7d87 /include/prereq-build.mk
parent0eb2fa39f313cac1e1e76c09e6ecf204064697a9 (diff)
downloadopenwrt-0ba83a757728185eabd965e07331508923cca825.tar.gz
openwrt-0ba83a757728185eabd965e07331508923cca825.tar.bz2
openwrt-0ba83a757728185eabd965e07331508923cca825.zip
build: require rsync
It seems to be required to build toolchain/kernel-headers. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index e7314b253b..5045fabdfb 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -170,6 +170,9 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
+$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
+ rsync --version </dev/null))
+
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<