summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-01-09 14:24:49 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-09 21:25:06 +0100
commit36bc306ae61133a4e7907f0648b8cf8ad8587619 (patch)
treed56076bb655c58b7c5c22ea9f1fb11c74026824b /include/prereq-build.mk
parent848b3445fba43b8ae2e1a299418551d8bc8cd400 (diff)
downloadopenwrt-36bc306ae61133a4e7907f0648b8cf8ad8587619.tar.gz
openwrt-36bc306ae61133a4e7907f0648b8cf8ad8587619.tar.bz2
openwrt-36bc306ae61133a4e7907f0648b8cf8ad8587619.zip
prereq-build: add extra check for elfutils required header
While testing tools build on an alpine image it was found that with musl libc some header are missing for elfutils tool. Add extra prereq-build check to make sure these header are present in the system to correctly compile host tools. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7959890eb5..7b345ebbaa 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -204,6 +204,18 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
/bin/which which, \
which which))
+$(eval $(call RequireCHeader,argp.h, \
+ Missing argp.h Please install the argp-standalone package if musl libc))
+
+$(eval $(call RequireCHeader,fts.h, \
+ Missing fts.h Please install the musl-fts-dev package if musl libc))
+
+$(eval $(call RequireCHeader,obstack.h, \
+ Missing obstack.h Please install the musl-obstack-dev package if musl libc))
+
+$(eval $(call RequireCHeader,libintl.h, \
+ Missing libintl.h Please install the musl-libintl package if musl libc))
+
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<