summaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-05-23 14:17:47 +0200
committerPetr Štetiar <ynezz@true.cz>2023-05-23 17:49:57 +0200
commit7855378fcd7ed7cb0a223238a99bac0b8e46c380 (patch)
treeedc0fae3a90d9d8159c5ecc9bec806bcf834f08d /include/prereq.mk
parente3a681bab4b2c193704e76b8a6091e57f0fab14e (diff)
downloadopenwrt-7855378fcd7ed7cb0a223238a99bac0b8e46c380.tar.gz
openwrt-7855378fcd7ed7cb0a223238a99bac0b8e46c380.tar.bz2
openwrt-7855378fcd7ed7cb0a223238a99bac0b8e46c380.zip
prereq: SetupHostCommand: fix wrong check result
Tony has reported, that CI tools job is failing for him in macOS container due to prereq check failure for GNU `install` utility. Michael diagnosed it and from his traces it was clear, that the issue is caused by a wrong return value in the success check case, so lets fix it accordingly. Fixes: f75204036ccc ("prereq-build: allow host command symlinks to update") Reported-by: Tony Ambardar <itugrok@yahoo.com> Diagnosed-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 5646b24efa..74c3914d06 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -113,7 +113,7 @@ define SetupHostCommand
;; \
esac; \
ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
- exit 1; \
+ exit 0; \
fi; \
fi; \
done; \