summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-04-19 17:34:18 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-04-23 09:19:33 +0800
commitb889d1e3cf0233e6efbf4b55197ab64aa8c0cd6a (patch)
tree39ec95ad0c58bf35bae5613d622b8ab52dc6f7c9 /include/target.mk
parente80a0413487d957d939eb670393e73d955a77d87 (diff)
downloadopenwrt-b889d1e3cf0233e6efbf4b55197ab64aa8c0cd6a.tar.gz
openwrt-b889d1e3cf0233e6efbf4b55197ab64aa8c0cd6a.tar.bz2
openwrt-b889d1e3cf0233e6efbf4b55197ab64aa8c0cd6a.zip
build: fix aarch64 default cpu selection
Not sure since when the issue emerged, but according to the current doc of gcc and as, armv8-a is intended as argument of -march The change will affect at the moment arm64 and layerscape/64b Below is the relevant error messages when building toolchain Assembler messages: Error: unknown cpu `armv8-a' Error: unrecognized option -mcpu=armv8-a /home/yousong/git-repo/lede-project/lede/build_dir/toolchain-aarch64_armv8-a_gcc-5.4.0_musl/gcc-5.4.0/libgcc/libgcc2.c:1:0: error: unknown value 'armv8-a' for -mcpu Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 3523d045ae..646057ca06 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -208,8 +208,8 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_ultrasparc = -mcpu=ultrasparc
endif
ifeq ($(ARCH),aarch64)
- CPU_TYPE ?= armv8-a
- CPU_CFLAGS_armv8-a = -mcpu=armv8-a
+ CPU_TYPE ?= generic
+ CPU_CFLAGS_generic = -mcpu=generic
CPU_CFLAGS_cortex-a53 = -mcpu=cortex-a53
endif
ifeq ($(ARCH),arc)