summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2024-01-06 09:26:33 -0800
committerPaul Spooren <mail@aparcar.org>2024-01-06 18:57:42 +0100
commit184bd28064bc591bf907c42afc9e0b9c1b9858b4 (patch)
treea12317c84852e9c704e3a3812653126598236f36 /include/toplevel.mk
parentebed3f65ea681f55b3ccfeb208664552970cb7fc (diff)
downloadopenwrt-184bd28064bc591bf907c42afc9e0b9c1b9858b4.tar.gz
openwrt-184bd28064bc591bf907c42afc9e0b9c1b9858b4.tar.bz2
openwrt-184bd28064bc591bf907c42afc9e0b9c1b9858b4.zip
build: fix toplevel check target
Partially revert changes to verbose logging that break the 'check' target dependencies and trigger many runtime warnings like: /home/kodidev/openwrt-project/include/toplevel.mk:213: *** mixed implicit and normal rules: deprecated syntax Fixes: e4a43cda0 ("build: allow var.% targets to bypass the prepare steps") Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 96f32139d9..f2dfde60cf 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -210,7 +210,9 @@ prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
check: .config FORCE
-check val.% var.%: FORCE
+ @+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
+
+val.% var.%: FORCE
@+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))