summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-21 12:21:40 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-21 12:43:45 +0200
commit8cc922411561dfa6f65fbb492a7bdb6fb9bbb6d5 (patch)
tree9fc8a0c515525e0ba8f47e607e260e5d03425498 /include/toplevel.mk
parent3b26a5bb15978914118a7958764f5c8079bf72f9 (diff)
downloadopenwrt-8cc922411561dfa6f65fbb492a7bdb6fb9bbb6d5.tar.gz
openwrt-8cc922411561dfa6f65fbb492a7bdb6fb9bbb6d5.tar.bz2
openwrt-8cc922411561dfa6f65fbb492a7bdb6fb9bbb6d5.zip
sdk: predefine SOURCE_DATE_EPOCH
When building packages within the SDK, there is no Git revision history available so prepopulate SOURCE_DATE_EPOCH in version.mk, similar to how we handle REVISION already. Acked-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index e13acafe9c..81329ac414 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -16,13 +16,14 @@ ifeq ($(SDK),1)
include $(TOPDIR)/include/version.mk
else
REVISION:=$(shell $(TOPDIR)/scripts/getver.sh)
+ SOURCE_DATE_EPOCH:=$(shell $(TOPDIR)/scripts/get_source_date_epoch.sh)
endif
HOSTCC ?= $(CC)
export REVISION
+export SOURCE_DATE_EPOCH
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))
-export SOURCE_DATE_EPOCH:=$(shell $(TOPDIR)/scripts/get_source_date_epoch.sh)
# prevent perforce from messing with the patch utility
unexport P4PORT P4USER P4CONFIG P4CLIENT