summaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorSergio E. Nemirowski <sergio@outerface.net>2020-06-10 04:33:21 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-07 19:47:24 +0200
commit8fb0b15efde92de43f6bc52f60a5a5680b782d8e (patch)
treee4f905790602347f84d5dd661d96ac204e0b6cf9 /include/toplevel.mk
parentae2d249056bdd7b87169e7c14f54c0c464b1acc5 (diff)
downloadopenwrt-8fb0b15efde92de43f6bc52f60a5a5680b782d8e.tar.gz
openwrt-8fb0b15efde92de43f6bc52f60a5a5680b782d8e.tar.bz2
openwrt-8fb0b15efde92de43f6bc52f60a5a5680b782d8e.zip
build: add nconfig
Add support for make target nconfig (ncurses) Reviewed-by: Eneas U de Queiroz <cotequeiroz@gmail.com> Signed-off-by: Sergio E. Nemirowski <sergio@outerface.net> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 5cf93ce7ef..ba59595764 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -141,6 +141,13 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
[ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; \
$< Config.in
+nconfig: scripts/config/nconf prepare-tmpinfo FORCE
+ if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+ cp $(HOME)/.openwrt/defconfig .config; \
+ fi
+ [ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; \
+ $< Config.in
+
xconfig: scripts/config/qconf prepare-tmpinfo FORCE
if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
cp $(HOME)/.openwrt/defconfig .config; \