summaryrefslogtreecommitdiffstats
path: root/include/u-boot.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-25 07:33:41 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-25 07:48:43 +0100
commit1c0addb15608b7a0d73fd056524f505df02eb5e3 (patch)
tree289feccc1c558a7f891bee6ed5c7ed11be61f6cd /include/u-boot.mk
parent1e14f01ed6d0cfff962c633bf130e96964c13e43 (diff)
downloadopenwrt-1c0addb15608b7a0d73fd056524f505df02eb5e3.tar.gz
openwrt-1c0addb15608b7a0d73fd056524f505df02eb5e3.tar.bz2
openwrt-1c0addb15608b7a0d73fd056524f505df02eb5e3.zip
u-boot.mk: add support for overriding DEFAULT
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/u-boot.mk')
-rw-r--r--include/u-boot.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index de62923352..0c28653326 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -32,6 +32,7 @@ define U-Boot/Init
NAME:=
DEPENDS:=
HIDDEN:=
+ DEFAULT:=
VARIANT:=$(1)
UBOOT_CONFIG:=$(1)
UBOOT_IMAGE:=u-boot.bin
@@ -59,6 +60,7 @@ define Build/U-Boot/Target
$(patsubst %,|| $(patsubst TARGET_%,TARGET_DEVICE_%,$(TARGET_DEP))_DEVICE_%,$(BUILD_DEVICES)))
endif
endif
+ $(if $(DEFAULT),DEFAULT:=$(DEFAULT))
URL:=http://www.denx.de/wiki/U-Boot
endef