summaryrefslogtreecommitdiffstats
path: root/include/u-boot.mk
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-10-13 12:51:22 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:00:49 +0200
commitf262d2aae136d2fe60c3b7314a4a0c5f30d79062 (patch)
tree6f652454977fc70b63df58eee5d1a63f3f04fd16 /include/u-boot.mk
parentb428f187f0db70a0a7166895ac9d159104ae5708 (diff)
downloadopenwrt-f262d2aae136d2fe60c3b7314a4a0c5f30d79062.tar.gz
openwrt-f262d2aae136d2fe60c3b7314a4a0c5f30d79062.tar.bz2
openwrt-f262d2aae136d2fe60c3b7314a4a0c5f30d79062.zip
u-boot.mk: fix pkg-config usage
Using Host/Exports doesn't work as intended, explicitly add the required vars so that u-boot finds the required libraries when building its tools. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'include/u-boot.mk')
-rw-r--r--include/u-boot.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index c0a1e87bf3..8c6941b88a 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -45,6 +45,9 @@ UBOOT_MAKE_FLAGS = \
HOSTCC="$(HOSTCC)" \
HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS) -std=gnu11" \
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
+ STAGING_PREFIX="$(STAGING_DIR_HOST)" \
+ PKG_CONFIG_PATH="$(STAGING_DIR_HOST)/lib/pkgconfig" \
+ PKG_CONFIG_LIBDIR="$(STAGING_DIR_HOST)/lib/pkgconfig" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='')
define Build/U-Boot/Target