summaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-12-02 22:11:40 +0100
committerJo-Philipp Wich <jo@mein.io>2016-12-14 18:43:49 +0100
commita4232cd4bfa9d244a0b763742564f22d15264839 (patch)
tree57dd510e6f22b1930cc1a67006b77806d5c13ddc /include/version.mk
parent98b14e0906cfe476da7a007cbf467b73b4c85acf (diff)
downloadopenwrt-a4232cd4bfa9d244a0b763742564f22d15264839.tar.gz
openwrt-a4232cd4bfa9d244a0b763742564f22d15264839.tar.bz2
openwrt-a4232cd4bfa9d244a0b763742564f22d15264839.zip
build: use SNAPSHOT instead of CURRENT to designate untagged branch builds
Calling a build ##.##-CURRENT might mislead users into thinking that this build is the most current release of a branch. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/version.mk b/include/version.mk
index a21bf25c7f..1a0d3c990b 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -31,7 +31,7 @@ qstrip_escape=$(subst ','\'',$(call qstrip,$(1)))
sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),CURRENT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
VERSION_CODE:=$(call qstrip_escape,$(CONFIG_VERSION_CODE))
VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))