summaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-01-31 15:48:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-01-31 15:48:42 +0000
commitab8f328e8c1400cc253e8771b07aa43716ca9a00 (patch)
tree53fc05df736e8cfc74cd472bb0c615b73d2be4db /include/version.mk
parentcc7b3e2465f57c92879e39690021b3276d4c61aa (diff)
downloadopenwrt-ab8f328e8c1400cc253e8771b07aa43716ca9a00.tar.gz
openwrt-ab8f328e8c1400cc253e8771b07aa43716ca9a00.tar.bz2
openwrt-ab8f328e8c1400cc253e8771b07aa43716ca9a00.zip
version.mk: add initial infrastructure for recording specific build taint conditions like modified busybox or disabled ipv6 support
SVN-Revision: 39436
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/include/version.mk b/include/version.mk
index 2bf709e56e..575398bc20 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -29,6 +29,30 @@ VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/
VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
+
+define taint2sym
+$(CONFIG_$(firstword $(subst :, ,$(subst +,,$(subst -,,$(1))))))
+endef
+
+define taint2name
+$(lastword $(subst :, ,$(1)))
+endef
+
+VERSION_TAINT_SPECS := \
+ -ALL:no-all \
+ -IPV6:no-ipv6 \
+ +USE_EGLIBC:eglibc \
+ +USE_MKLIBS:mklibs \
+ +BUSYBOX_CUSTOM:busybox \
+
+VERSION_TAINTS := $(strip $(foreach taint,$(VERSION_TAINT_SPECS), \
+ $(if $(findstring +,$(taint)), \
+ $(if $(call taint2sym,$(taint)),$(call taint2name,$(taint))), \
+ $(if $(call taint2sym,$(taint)),,$(call taint2name,$(taint))) \
+ )))
+
+PKG_CONFIG_DEPENDS += $(foreach taint,$(VERSION_TAINT_SPECS),$(call taint2sym,$(taint)))
+
VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%V,$(VERSION_NUMBER),g' \
-e 's,%v,\L$(subst $(space),_,$(VERSION_NUMBER)),g' \
@@ -41,3 +65,4 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%R,$(REVISION),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
+ -e 's,%t,$(VERSION_TAINTS),g' \