summaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-04-08 08:05:29 +0200
committerPaul Spooren <mail@aparcar.org>2024-04-08 21:53:05 +0200
commitd997477775bf5447000f1d300a027878b566f5d1 (patch)
tree182215d7e6843ec0d4e02a53d8af567005f0411e /include/version.mk
parent3ce1e4c3d3da3885c2f42e1aa5bc97e0d421445b (diff)
downloadopenwrt-d997477775bf5447000f1d300a027878b566f5d1.tar.gz
openwrt-d997477775bf5447000f1d300a027878b566f5d1.tar.bz2
openwrt-d997477775bf5447000f1d300a027878b566f5d1.zip
treewide: remove implicit SUBTARGET
Historically it's possible to leave the `SUBTARGETS` undefined and automatically fallback to a "generic" subtarget. This however breaks various downstream scripts which may have expectations around filenames: While some targets with an explicit generic subtarget contain `generic` in the filenames of artifacts, implicit "subtargets" don't. Right now this breaks the CI[1], possibly also scripts using the ImageBuilders. This commit removes all code that support implicit handling of subtargets and instead requires every target to define "SUBTARGETS". [1]: https://github.com/openwrt/openwrt/actions/runs/8592821105/job/23548273630 Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/version.mk b/include/version.mk
index f39e35cd09..cdee0976da 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -95,7 +95,7 @@ VERSION_SED_SCRIPT:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
-e 's,%d,\L$(call sed_escape,$(subst $(space),_,$(VERSION_DIST))),g' \
-e 's,%R,$(call sed_escape,$(REVISION)),g' \
-e 's,%T,$(call sed_escape,$(BOARD)),g' \
- -e 's,%S,$(call sed_escape,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic)),g' \
+ -e 's,%S,$(call sed_escape,$(BOARD)/$(SUBTARGET)),g' \
-e 's,%A,$(call sed_escape,$(ARCH_PACKAGES)),g' \
-e 's,%t,$(call sed_escape,$(VERSION_TAINTS)),g' \
-e 's,%M,$(call sed_escape,$(VERSION_MANUFACTURER)),g' \