summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2024-01-07 23:56:05 +0800
committerChuanhong Guo <gch981213@gmail.com>2024-01-07 23:56:05 +0800
commit066b0fee76684a9fca44635d63bf2c699ef8e89c (patch)
tree014497ad9df6a84a208ae27ab38400fec6e822f5 /include
parent96580500d2806136a98cf38657e7c6082dab7e1c (diff)
downloadopenwrt-066b0fee76684a9fca44635d63bf2c699ef8e89c.tar.gz
openwrt-066b0fee76684a9fca44635d63bf2c699ef8e89c.tar.bz2
openwrt-066b0fee76684a9fca44635d63bf2c699ef8e89c.zip
kernel: copy only *.ko for debug info
Previous commits installed non-elf files into /lib/modules/$VER/. COLLECT_KERNEL_DEBUG tries to strip all files and these two files break the build. Fix it by copying only kernel modules for debug info collection. Fixes: e1d8e57614 ("kernel: include modinfo for built-in modules") Fixes: 29f6da4340 ("kernel: include built-in module list") Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 5b332258f8..b9513ec414 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -63,7 +63,7 @@ ifdef CONFIG_COLLECT_KERNEL_DEBUG
mkdir -p $(KERNEL_BUILD_DIR)/debug/modules
$(CP) $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/debug/
-$(CP) \
- $(STAGING_DIR_ROOT)/lib/modules/$(LINUX_VERSION)/* \
+ $(STAGING_DIR_ROOT)/lib/modules/$(LINUX_VERSION)/*.ko \
$(KERNEL_BUILD_DIR)/debug/modules/
$(FIND) $(KERNEL_BUILD_DIR)/debug -type f | $(XARGS) $(KERNEL_CROSS)strip --only-keep-debug
$(TAR) c -C $(KERNEL_BUILD_DIR) debug \