summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-02-12 16:59:50 +0100
committerPaul Spooren <mail@aparcar.org>2024-02-12 17:06:41 +0100
commit131e41614dcfae1f995e55330ada6573ca244ba3 (patch)
tree65f2caac878392baa1f903e421258ee34e11a263 /include
parent6497cdba09d6faa04a4f74465ed95ae21e2ff1ff (diff)
downloadopenwrt-131e41614dcfae1f995e55330ada6573ca244ba3.tar.gz
openwrt-131e41614dcfae1f995e55330ada6573ca244ba3.tar.bz2
openwrt-131e41614dcfae1f995e55330ada6573ca244ba3.zip
build: align SOURCE path for build system and SDK
Building a package in the build system or the SDK results in different values for the `SOURCE` property, it's either `packages/<package name>` or `feeds/base/<package name>`. The reason is that the SDK handles `openwrt.git` as an external feed called while the build system contains the *base* packages directly. Since packages created with either method are (ideally) the same (bit for bit), align the content of SOURCE. To do so this commit creates a symlink from `feeds/base` to `$(TOPDIR)/package` and adopts the SOURCE when building from inside the build system. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include')
-rw-r--r--include/package-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 30b112c7d8..392aad0d5d 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -20,7 +20,7 @@ define Package/Default
PROVIDES:=
EXTRA_DEPENDS:=
MAINTAINER:=$(PKG_MAINTAINER)
- SOURCE:=$(patsubst $(TOPDIR)/%,%,$(CURDIR))
+ SOURCE:=$(patsubst $(TOPDIR)/%,%,$(patsubst $(TOPDIR)/package/%,feeds/base/%,$(CURDIR)))
ifneq ($(PKG_VERSION),)
ifneq ($(PKG_RELEASE),)
VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)