summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-02-16 13:55:12 +0000
committerDaniel Golle <daniel@makrotopia.org>2024-02-16 13:56:01 +0000
commit132331408793d8fe9a613e825ac8b56878a2d2a8 (patch)
tree1b2077b18f2caca1965e11226d691ba7120d6fe4 /include
parent667d109d0fc8e3f64c6a47ca9cb40576a486a313 (diff)
downloadopenwrt-132331408793d8fe9a613e825ac8b56878a2d2a8.tar.gz
openwrt-132331408793d8fe9a613e825ac8b56878a2d2a8.tar.bz2
openwrt-132331408793d8fe9a613e825ac8b56878a2d2a8.zip
images: append to existing image with ubinize-image build cmd
Let ubinize-image append the ubinized image to the existing image instead of replacing it. Fixes: 6c17d71973 ("scripts: ubinize-image.sh: support static volumes, make size optional") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8caeb1871c..79a64f4bc1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -157,11 +157,13 @@ define Build/ubinize-image
$(if $(UBOOTENV_IN_UBI),--uboot-env) \
$(foreach part,$(UBINIZE_PARTS),--part $(part)) \
--part $(word 1,$(1))="$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(word 2,$(1))" \
- $@ \
+ $@.tmp \
-p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
$(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
$(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
$(UBINIZE_OPTS)
+ cat $@.tmp >> $@
+ rm $@.tmp
endef
define Build/ubinize-kernel