summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-18 12:32:57 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-19 14:31:56 +0100
commit2d9d57b9de230e1f397c1396f4fb7dfae34d3855 (patch)
treed80c10e4e44c4b81a5d453db222094529224bb7a /include
parent797e5c1c48e6a5b8866504ea42bd7298c63ad3d5 (diff)
downloadopenwrt-2d9d57b9de230e1f397c1396f4fb7dfae34d3855.tar.gz
openwrt-2d9d57b9de230e1f397c1396f4fb7dfae34d3855.tar.bz2
openwrt-2d9d57b9de230e1f397c1396f4fb7dfae34d3855.zip
build: rename .packagesubdirs to .packageauxvars
Subsequent commits will put more auxiliary information into this file, such as the per-package ABI version, so rename the metadata script subcommand and file names accordingly. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk2
-rw-r--r--include/toplevel.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index d20cdfe069..a908a5720a 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -6,7 +6,7 @@
# See /LICENSE for more information.
#
--include $(TMP_DIR)/.packagesubdirs
+-include $(TMP_DIR)/.packageauxvars
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
diff --git a/include/toplevel.mk b/include/toplevel.mk
index b57dcd8544..36f790f807 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -88,9 +88,9 @@ prepare-tmpinfo: FORCE
f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \
[ "$$t" -nt "$$f" ] || ./scripts/$${type}-metadata.pl $(_ignore) config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
done
- [ tmp/.config-feeds.in -nt tmp/.packagesubdirs ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
+ [ tmp/.config-feeds.in -nt tmp/.packageauxvars ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
./scripts/package-metadata.pl mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
- ./scripts/package-metadata.pl subdirs tmp/.packageinfo > tmp/.packagesubdirs || { rm -f tmp/.packagesubdirs; false; }
+ ./scripts/package-metadata.pl pkgaux tmp/.packageinfo > tmp/.packageauxvars || { rm -f tmp/.packageauxvars; false; }
touch $(TOPDIR)/tmp/.build
.config: ./scripts/config/conf $(if $(CONFIG_HAVE_DOT_CONFIG),,prepare-tmpinfo)