summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-25 12:48:43 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-29 14:30:32 +0100
commit396a35dd51f1d58c051d0c1f1100e44950933d3b (patch)
tree8132a2fec84e13f55843233020780a92abeaefa8 /include
parent331892f85f1cfab21b26a1f84824f4110e06027f (diff)
downloadopenwrt-396a35dd51f1d58c051d0c1f1100e44950933d3b.tar.gz
openwrt-396a35dd51f1d58c051d0c1f1100e44950933d3b.tar.bz2
openwrt-396a35dd51f1d58c051d0c1f1100e44950933d3b.zip
base-files: remove execute bit and shebang from functions.sh
/lib/functions.sh was executable for no obvious reason and its execute property was even checked in package-ipkg.mk just to source it afterwards. Remove the execute bit and shebang as this is clearly a library. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Reviewed-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index a92d692121..32de3cc93e 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -232,13 +232,13 @@ $(_endef)
( \
echo "#!/bin/sh"; \
echo "[ \"\$$$${IPKG_NO_SCRIPT}\" = \"1\" ] && exit 0"; \
- echo "[ -x "\$$$${IPKG_INSTROOT}/lib/functions.sh" ] || exit 0"; \
+ echo "[ -s "\$$$${IPKG_INSTROOT}/lib/functions.sh" ] || exit 0"; \
echo ". \$$$${IPKG_INSTROOT}/lib/functions.sh"; \
echo "default_postinst \$$$$0 \$$$$@"; \
) > postinst; \
( \
echo "#!/bin/sh"; \
- echo "[ -x "\$$$${IPKG_INSTROOT}/lib/functions.sh" ] || exit 0"; \
+ echo "[ -s "\$$$${IPKG_INSTROOT}/lib/functions.sh" ] || exit 0"; \
echo ". \$$$${IPKG_INSTROOT}/lib/functions.sh"; \
echo "default_prerm \$$$$0 \$$$$@"; \
) > prerm; \