summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2024-02-25 20:33:08 +0800
committerChristian Lamparter <chunkeey@gmail.com>2024-03-02 14:17:31 +0100
commit4f668091bfd608b73f4b98b206358d8f1a7ffade (patch)
tree402bc4fb52a5b014cb7b5b619484448e95c9a597 /include
parent8256d06933e7542ecdd427b6a0ef4e87bb37d3f4 (diff)
downloadopenwrt-4f668091bfd608b73f4b98b206358d8f1a7ffade.tar.gz
openwrt-4f668091bfd608b73f4b98b206358d8f1a7ffade.tar.bz2
openwrt-4f668091bfd608b73f4b98b206358d8f1a7ffade.zip
u-boot.mk: override default PATH to avoid pick hostpkg python
hostpkg python from packages feed can be picked when do a incremental build because hostpkg has higher priority in PATH. It may lead build faliure as it's heavily trimmed (e.g. lacks necessary modules). For uboot which uses binman and intree dtc, this is forced as hostpkg python will never provide those modules by default. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'include')
-rw-r--r--include/u-boot.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 06867a70e4..454880989b 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -69,6 +69,7 @@ endef
TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
UBOOT_MAKE_FLAGS = \
+ PATH=$(STAGING_DIR_HOST)/bin:$(PATH) \
HOSTCC="$(HOSTCC)" \
HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS) -std=gnu11" \
HOSTLDFLAGS="$(HOST_LDFLAGS)" \