summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-08-14 08:51:36 -1000
committerDaniel Golle <daniel@makrotopia.org>2019-08-22 12:57:34 +0200
commit58aab7379767bb95ff2ccd9eaad76cea83fcc939 (patch)
tree65c3ec16e8e6c51aaabd47e48ac67915f20f81bb /include
parentfd666870582f5f220165d6df46b085a6450b6051 (diff)
downloadopenwrt-58aab7379767bb95ff2ccd9eaad76cea83fcc939.tar.gz
openwrt-58aab7379767bb95ff2ccd9eaad76cea83fcc939.tar.bz2
openwrt-58aab7379767bb95ff2ccd9eaad76cea83fcc939.zip
image.mk: keep underscores when sanitize PROFILE
Underscores don't harm in filenames, however the sanitize function from version.mk replaces them, causing inconsistent filenames. A fix tried to solve this previously via dfe99645dbdd4460f394beaa3a05091cd40b5942 however I did not look close enough: openwrt-ath79-generic-8dev-carambola2.manifest # current openwrt-ath79-generic_8dev-carambola2.manifest # patched ---------------------^ Eventually the sanitization of PROFILES *could* be removed as more and more profiles follow the device tree approach of vendor_model, neither containing upper case letters nor spaces. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 25df29ddf3..5d54bc7947 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -106,7 +106,7 @@ define add_jffs2_mark
echo -ne '\xde\xad\xc0\xde' >> $(1)
endef
-PROFILE_SANITIZED := $(call sanitize,$(subst DEVICE_,,$(PROFILE)))
+PROFILE_SANITIZED := $(call tolower,$(subst DEVICE_,,$(subst $(space),-,$(PROFILE))))
define split_args
$(foreach data, \