summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-07-28 00:33:32 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-15 22:53:01 +0200
commit60eb0e8da2aa5df7cbbea657d6a809b29e818ad8 (patch)
treeb2d0c0b235d3da3e064a96a894ebc822240044d9 /include
parent296e1f253c77a2cbf5364a0e9f83fd9946ce9dbf (diff)
downloadopenwrt-60eb0e8da2aa5df7cbbea657d6a809b29e818ad8.tar.gz
openwrt-60eb0e8da2aa5df7cbbea657d6a809b29e818ad8.tar.bz2
openwrt-60eb0e8da2aa5df7cbbea657d6a809b29e818ad8.zip
scons: move to packages feed
This patch removes scons host build tool, as commit 7087efd72a8d ("scons: move host build tool to a proper place") in the packages feed has moved scons into the new home. There are currently no packages in the master tree which would need scons, yet scons is build always as part of host tools, just in order to satisfy host build dependency of few packages in the packages feeds. Ref: https://github.com/openwrt/packages/pull/9584 Acked-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include')
-rw-r--r--include/scons.mk23
1 files changed, 0 insertions, 23 deletions
diff --git a/include/scons.mk b/include/scons.mk
deleted file mode 100644
index 2b76710542..0000000000
--- a/include/scons.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-export PLATFORM=posix
-
-SCONS_VARS = \
- CC="$(TARGET_CC_NOCACHE)" \
- CXX="$(TARGET_CXX_NOCACHE)" \
- CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
- CXXFLAGS="$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)" \
- CPPFLAGS="$(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)"
-
-define Build/Configure/Default
- (cd $(PKG_BUILD_DIR); \
- $(SCONS_VARS) \
- scons \
- prefix=/usr \
- $(SCONS_OPTIONS) \
- install \
- )
-endef
-
-define Build/Compile
-endef