summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-02-22 19:13:34 +0000
committerChristian Marangi <ansuelsmth@gmail.com>2024-02-23 15:59:09 +0100
commit68968fc981b7804032eba0339a40054f39e0d22f (patch)
tree2c15f61a85657ce81d5990e920413b8877d8c778 /include
parentae2dced6cec71f56432386e49e0150fdaa1e35e0 (diff)
downloadopenwrt-68968fc981b7804032eba0339a40054f39e0d22f.tar.gz
openwrt-68968fc981b7804032eba0339a40054f39e0d22f.tar.bz2
openwrt-68968fc981b7804032eba0339a40054f39e0d22f.zip
Revert "build: don't drop 'user' flag when using the ImageBuilder"
This reverts commit c42b915af0ea53bc1b65bc72afc9875da08b14d2. Now that rpcd uses the 'Auto-Installed' field to differentiate between deliberately and implicitely installed packages we can remove the hotfix. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/rootfs.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index b07f33d204..2128aefc2a 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -87,11 +87,11 @@ define prepare_rootfs
fi; \
done || true \
)
- $(if $(IB),,awk -i inplace \
+ awk -i inplace \
'/^Status:/ { \
if ($$3 == "user") { $$3 = "ok" } \
else { sub(/,\<user\>|\<user\>,/, "", $$3) } \
- }1' $(1)/usr/lib/opkg/status)
+ }1' $(1)/usr/lib/opkg/status
$(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(1)/usr/lib/opkg/status)
@-find $(1) -name CVS -o -name .svn -o -name .git -o -name '.#*' | $(XARGS) rm -rf
rm -rf \